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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For example,
“copy file1” means you must type the word copy, then type a space, and then type
file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to press
the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then type a
space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and
contains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an
application arranged by category such File, Edit, View, Project, etc. An example of a
typical user interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type)opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
ThisGetting Started Guide leads you step-by-step through creating, solving, and analyzing the
results of a parameterized 3D model representing a via on a Printed Circuit Board.

This guide outlines how to perform the following tasks in Q3D:

l Drawing a geometric model
l Setting up vias and traces
l Modifying a model’s design parameters
l Assigning variables to a model’s design parameters
l Specifying solution and design settings
l Validating a design’s setup
l Running a simulation
l Creating a plot of results

The Via Model
The via consists of a central cylinder and three thin cylindrical copper pads. It passes through a
clearance hole (antipad) in a large copper ground plane. The entire structure is embedded in an
FR-4 dielectric material.

The via model is shown below.

You will extract the parasitic inductance, resistance, and capacitance of this via. The drill hole
radius and the pad radius should be made variable quantities so that you can conduct a
parametric study of their effects.

Getting Started with Q3D Extractor®: A 3D PCB Via Model
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2 - Creating the Via Model
This section explains how to perform the following tasks:

l Creating and saving a new project
l Setting the model units for the design
l Drawing a model
l Creating and assigning variables
l Setting the background material

Creating and Saving a New Project
A project is a collection of one or more designs that is saved in a single file. A new, blank project
is automatically created when Electronics Desktop is launched.

To launch Electronics Desktop, add a Q3D design, and save a new project:

1. Double-click the Ansys Electronics Desktop icon on your desktop.

A new project appears in the Project Manager window, named Project#. The number
depends on the number of projects previously saved. Beneath the project are folders
containing project definitions.

2. Select Project > Insert Q3D Design.

A Q3D design appears beneath the project name, named Q3DDesign#. The number
depends on the number of designs previously added to the project.

Getting Started with Q3D Extractor®: A 3D PCB Via Model
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An asterisk (*) next to the project name means there are unsaved changes.

3. Click File > Save As.

The Save As dialog box appears.

4. Select a location to save the file.
5. In the File Name field, type via_gsgand click Save.

The project is saved as via_gsg.aedt in the folder you selected.

6. Rename the default design:
a. From the Project Manager window, right-clickQ3DDesign1 and select Rename.
b. Type ViaModel and press Enter.

Setting Drawing Units
To set the model's unit of measure:

Creating the Via Model 2-2
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1. ClickModeler > Units.

The Set Model Units and Max Extent dialog box appears.

2. Verify thatmm is selected in the Select units drop-down list.
3. ClickOK.

Enabling Legacy View Orientation

To ensure that your modeling window resembles the screenshots in this Getting Started Guide:

Creating the Via Model 2-3
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1. Select View > Options.
2. On theGeneral tab, ensure that Enable Legacy View Orientation is selected.

For more information on Legacy View, consult the Q3D Extractor help topic "View Options:
3D UI Options."

Drawing the Model
Drawing this model consists of the following steps:

1. Drawing a cylinder for the via's central barrel.
2. Drawing a cylinder for the via pad.
3. Duplicating the via pad to create two additional pads.

Creating the Via Model 2-4
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4. Drawing boxes for trace stubs.
5. Uniting the via pieces into a single object.
6. Drawing a box for the ground plane.
7. Drawing a cylinder for the antipad.

As you follow these steps, this section will also show you how to create and apply design
variables.

Creating the Via's Central Barrel
Create the first cylinder:

1. Click Draw > Cylinder.

The Measure Data dialog box appears.

2. Specify the radius:
a. Click at the origin of the XYZ coordinate system.

Important:

Do not move your cursor while specifying the information below.

b. Press Tab to move the cursor to the dX field.
c. Type 0.2 in the dX field, and then press Tab to move to the dY box.
d. Type 0.0 in the dY field, and then press Tab to move to the dZ box.
e. Type 0.0 in the dZ field, and press Enter.

The radius of the cylinder becomes fixed, and the height of the cylinder changes
dynamically as you move the cursor.

3. Specify the height of the cylinder:
a. Move the cursor over the z-axis.
b. Click when dZ displays 0.8.

The History Tree updates to display the CreateCylinder command. This command can
also be viewed in the Properties window, on the Command tab.

The Properties window's Attribute tab displays information about the newly created
Cylinder1 object.

4. If it is not already selected, click the Attribute tab to see the properties associated with the
cylinder.

5. Change the name of the cylinder to Via:
a. Click the Value text box in the Name row.
b. Type Via, and press Enter.

Creating the Via Model 2-5

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Q3D Extractor®: A 3D PCB Via Model

6. In the Value text box in theMaterial row, verify that the material type is copper.
7. ClickOK.

Creating the First Via Pad
Now you will create another cylinder to represent the via pad.

1. Click Draw > Cylinder.
2. Create a cylinder by specifying the radius and height:

a. Click at the origin of the XYZ coordinate system.

Important:

Do not move your cursor while specifying the information below.

b. Press Tab to move the cursor to the dX field.
c. Type 0.6 in the dX field, and then press Tab to move to the dY box.
d. Type 0.0 in the dY field, and then press Tab to move to the dZ box.
e. Type 0.025 in the dZ field, and press Enter.

3. Click on the Properties window's Attribute tab to see all the properties associated with
the cylinder.

4. Change the name of the cylinder to Pad1.
5. In the Value text box in theMaterial row, verify that the material type is copper.
6. ClickOK.

After these steps, your model should look similar to:

Creating the Via Model 2-6
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Duplicating the First Via Pad
Now you will create two more via pads from the first one.

1. Click Pad1 in the modeling workspace.
2. Click Edit > Duplicate > Along Line.
3. Specify the distance between pads as 0.4mm:

a. Click at the origin of the XYZ coordinate system.

Important:

Do not move your cursor while specifying the information below.

b. Press Tab to move to the dX field.
c. Type 0 in the dX field, and then press Tab to move to the dY box.
d. Type 0 in the dY field, and then press Tab to move to the dZ box.
e. Type 0.4 in the dZ field, and press Enter.

Creating the Via Model 2-7
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The Duplicate along line dialog box appears, and the model updates to preview the
duplication.

4. Type 3 in the Total number box.
5. Ensure that Attach to Original Object is not selected.
6. ClickOK.

Pad1 is duplicated 2 times. By default, the new objects are called Pad1_1 and Pad1_2.

Creating Geometric Variables
You will now define variables for the radius of the center barrel and the pads. Later, you will
modify their values.

Creating the Via Model 2-8
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1. ClickQ3D Extractor > Design Properties.

The Properties window appears, with no data listed.

2. Click Add.

The Add Property window appears.

3. Type viarad in the Name box.
4. Use the Unit Type drop-down menu to select Length.
5. Use the Units drop-down menu to selectmm.
6. Type 0.2 in the Value box.

7. ClickOK.

The Properties window updates to display the new variable.

8. Click Add again.
9. In the Add Property window:

a. Type padrad in the Name box.
b. Use the Unit Type drop-down menu to select Length.
c. Use the Units drop-down menu to selectmm.

Creating the Via Model 2-9

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Q3D Extractor®: A 3D PCB Via Model

d. Type 0.6 in the Value box.

e. ClickOK to add the variable and return to the Properties window.

Both new variables are listed.

Creating the Via Model 2-10
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10. ClickOK to close the Properties window and return to the model.

Assigning a Variable to the Center Barrel
After you have defined the variables, you will need to assign them.

You previously specified the via’s radius to be 0.2mm.

You will now replace that value with the viarad variable:

Creating the Via Model 2-11
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1. From the History Tree, select the CreateCylinder action under Via.

The Properties window updates to display a Command tab.

2. Assign the variable viarad to the radius:

Creating the Via Model 2-12
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a. In the Radius row, click the Value field.
b. Type viarad, and press Enter.

The Properties window updates, but the modeling workspace remains unchanged because the
variable holds the same value.

Assigning a Variable to the Pads
You previously specified the pad’s radius to be 0.6mm.

You will now replace that value with the padrad variable:

Creating the Via Model 2-13
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1. From the History Tree, select the CreateCylinder action under Pad1.

The Properties window updates to display the Command tab.

2. Assign the variable padrad to the radius:
a. In the Radius row, click the Value field.
b. Type padrad, and press Enter.

Creating the Via Model 2-14
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The Properties window updates, but the modeling workspace remains unchanged
because the variable holds the same value.

3. ClickQ3D Extractor > Design Properties.

The Properties window appears.

Creating the Via Model 2-15
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4. In the padrad row, type 0.5 in the Value field.

5. ClickOK.

The model updates. The radius changes for all three of the pads, since Pad1_1 and
Pad1_2 inherit changes to Pad1.

6. ClickQ3D Extractor > Design Properties to reopen the Properties window.

Creating the Via Model 2-16
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7. Reset the Value of padrad to 0.6, and verify that the Value for viarad is set to 0.2.

The model should look like the following:

Creating the Via Model 2-17
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Drawing the Trace Stubs
You will now add some trace stubs to the via model. Draw stubs to represent traces connecting
to the top and bottom of the via.

1. Click Draw > Box.
2. Use the status bar to specify the location of the base corner of the box (-0.25, 0.4, 0):

Important:

Do not move your cursor while specifying the information below.

a. Press Tab to move to the X box in the status bar.
b. Type -0.25 in the X field, and then press

Tab
to move to the Y field.

Creating the Via Model 2-18

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Q3D Extractor®: A 3D PCB Via Model

c. Type 0.4 in the Y field, and then press Tab.
d. Type 0 in the Z field, and then press Enter.

3. Without moving your cursor, continue using the status bar to specify the dimensions of the
box:
a. Press Tab to move to the dX field in the status bar.
b. Type 0.5 in the dX field, and then press Tab to move to the dY field.
c. Type 1.2 in the dY box, and then press Tab.
d. Type 0.025 in the dZ box and then press Enter.

A new object called Box1 is created.

The Attribute tab of the Properties window displays the details for Box1.

4. Verify that theMaterial for Box1 is set to copper.
5. Repeat steps 1 through 3 to create another box, Box2. This box should have the following

values:

X = -0.25 Y = -
0.4 Z = 0.8

dX = 0.5 dY = -
1.2

dZ =
0.025

The model should look like the following:
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The trace stubs created here partially overlap the pads. The via's center barrel also
overlaps the pad objects.

Partially overlapping objects can create ambiguity about the type of material to be used in
the overlap region. In the special case of one object being completely contained within
another, it is assumed that the material of the smaller object applies within the overlap
region. This is the only case in which overlapping objects are allowed.

Uniting Via Objects
The partial overlaps between the various objects in this model must be eliminated.

Since all the objects are of the same material (copper), you can unite them into a single solid
object:

1. Click Edit > Select All.
2. ClickModeler > Boolean > Unite.

The list of objects is replaced by a single object named Box2 that occupies the same
volume of space as the original set of objects.

Creating the Via Model 2-20
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The material type of Box2 is copper.

3. In the Properties window, use the Name field to rename Box2 to Via1.

TheModeler window should look like the following:

Creating the Via Model 2-21

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Q3D Extractor®: A 3D PCB Via Model

Creating the Ground Plane
You will create the ground plane as a box:

1. Click Draw > Box.

The Measure Data dialog box appears.

2. Specify the base corner of the box:
a. Press Tab to move the cursor to the X field.

Important:

Do not move your cursor while specifying the information below.

b. Type -5 in the X field, and then press Tab to move to the dY box.
c. Type -5 in the Y field, and then press Tab to move to the dZ box.
d. Type 0.4 in the Z field, and press Enter.

Creating the Via Model 2-22
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3. Specify the dimensions of the box:
a. Press Tab to move the cursor to the dX field.

Important:

Do not move your cursor while specifying the information below.

b. Type 10 in the dX field, and then press Tab to move to the dY box.
c. Type 10 in the dY field, and then press Tab to move to the dZ box.
d. Type 0.025 in the dZ field, and press Enter.

A new box named Box2 is created.

4. Use the Name field in the Properties window to rename Box2 toGroundPlane.
5. Set the modeling workspace to show the entire model by clicking View > Fit All > Active

View.
6. To view model overlapping, makeGroundPlane transparent:

a. SelectGroundPlane.
b. In the Properties window, select the Attribute tab.
c. Click the Value box next to Transparent. By default, the box displays a 0.

The Set Transparency dialog box appears.

d. Use the slider or enter 0.5 in the text field to set the value.
e. ClickOK.

The Transparent button in the Properties window updates to display 0.5.

The model updates to look like the following:
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The overlap will be corrected in the next step.

Creating the Antipad
To prevent the via from shorting to the ground plane, create a circular hole (or antipad) in the
plane.

Create the first cylinder:

1. Click Draw > Cylinder.

The Measure Data dialog box appears.

Important:

Do not move your cursor while specifying the information below.

2. Specify the location of the cylinder:
a. Press Tab to move the cursor to the X field.
b. Type 0.0 in the X field, and then press Tab to move to the Y box.
c. Type 0.0 in the Y field, and then press Tab to move to the Z box.
d. Type 0.4 in the Z field, and press Enter.
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3. Specify the size of the cylinder:
a. Press Tab to move the cursor to the dX field.
b. Type 1.25 in the dX field, and then press Tab to move to the dY box.
c. Type 0 in the dY field, and then press Tab to move to the dZ box.
d. Type 0.025 in the dZ field, and press Enter.

The History Tree updates to display Cylinder1 with an underlying CreateCylinder
command.

The Properties window's Attribute tab displays information about the newly created
Cylinder1 object.

4. If it is not already selected, click the Attribute tab to see the properties associated with the
cylinder.

5. Change the name of the cylinder to Hole:
a. Click the Value text box in the Name row.
b. Type Hole, and press Enter.

Next, you will remove Hole fromGroundPlane:

1. Ctrl+click the Hole andGroundPlane objects to select both.
2. ClickModeler > Boolean > Subtract.

The Subtract dialog box appears.

3. Use the arrows to ensure thatGroundPlane is listed under Blank Parts and Hole is
under Tool Parts.

4. ClickOK.

A circular hole is created in GroundPlane. The model should look like the following:

Creating the Via Model 2-25

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Q3D Extractor®: A 3D PCB Via Model

Setting the Background Material
You have now completed all of the 3D drawing operations for the metal objects in the problem.
By default, Q3D Extractor uses “vacuum” as the background material. However, for this project,
the via must be modeled in an FR-4 substrate, so the surrounding material needs to be changed.

To change the background material:

1. ClickQ3D Extractor > Set Background Material.

The Select Definition window appears.
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2. Select FR4_epoxy from the list of materials, and clickOK.
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3 - Setting Up the Simulation and Viewing
Results

This section explains how to perform the following tasks:

l Changing Q3D design settings
l Setting up sources and sinks for inductance and resistance calculations
l Identifying nets
l Adding a solution setup
l Validating the design
l Requesting the parameters (R, L, C) for which to solve and launching the simulation
l Viewing results as a field plot
l Exporting a Circuit model

Changing Q3D Design Settings
To ensure frequency sweeps run correctly, you must use causal materials. Q3D Extractor can be
set to automatically use causal materials from the Q3D Design Settings window:

1. ClickQ3D Extractor > Design Settings.

TheQ3D Design Settings window appears.

2. Select the Lossy Dielectrics tab.
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3. Enable Automatically use causal materials.

4. Click OK.

Setting Up Sources and Sinks
To set up the solution for resistance and inductance, you will need to first define source and sink
terminals. Attached to each source terminal is an independent current source. Assume that
current enters and leaves at the ends of the two trace stubs you created. You need to put a
source at the end of the top stub, and a sink at the end of the bottom stub.
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Defining the Source
1. Click View > Visibility > Active View Visibility.

The Active View Visibility dialog box appears.

2. Clear the Visibility check box forGroundPlane, and click Done.

GroundPlane disappears from view.

3. In the modeling workspace, select Via.
4. Click View > Fit Selections > All Views.

The model zooms so that Via fills the modeling workspace.

5. Rotate the model so that you are looking at the end of the top trace stub:
l Click View > Interaction > Rotate Screen Center, and then click-and-drag the model
to spin it around.

6. Right-click in the modeling workspace and choose Selection Mode > Faces.
7. Click to select the face of the top stub.

8. Right-click in theModeler window, and then click Assign Excitation > Source from the
shortcut menu.

The Source dialog box appears.
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9. Leave the default settings and clickOK.

Assigning the Sink
The sink terminal collects all of the current injected at the source terminals and allows it to flow
out of the conductor back into the independent sources, completing the electrical circuit.

1. Rotate the model so that you are looking at the end of the bottom trace stub:
l Click View > Interaction > Rotate Screen Center, and then click-and-drag the model
to spin it around.
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2. Click to select the face of the bottom stub.

3. Right-click in theModeler window, and then click Assign Excitation > Sink from the
shortcut menu.

The Sink dialog box appears.
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4. Leave the default settings and clickOK.

Finally, restore ground plane visibility and orient the model:

1. Click View > Visibility > Active View Visibility.
2. Enable the visibility check box forGroundPlane and click Done.
3. From the Draw tab, selectOrient > Dimetric.

The model should look like the following:

Identifying the Nets
The model is almost ready for simulation. The final step is to define the distinct nets.

To automatically create nets:
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1. Right-click in the modeling workspace and select Auto Identify Nets.

The Project Manager window updates to show two nets:GroundPlane and Via1.
Beneath Via1, it shows Source1 and Sink1.

Adding a Solution Setup
Now start solving for the electrical parasitics of the via.

1. In the Project Manager window, right-click Analysis and select Add Solution Setup.

The Solve Setup window appears.

2. On theGeneral tab, verify that Capacitance/Conductance, DC Resistance/Inductance
and AC Resistance/Inductance are selected.

3. Enable the Save Fields check box.
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4. In the Solution Frequency field, specify 100 MHz.

5. ClickOK.

The new setup (Setup1) can be found under Analysis in the Project Manager window.
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Validating the Design
You must verify that all the steps have been properly completed before you launch the
simulation.

1. ClickQ3D Extractor > Validation Check.

The Validation Check dialog box appears, and displays a progress bar.

When the check is complete, the message 'Validation Check completed' appears.

If all checks were successful, only green check marks appear.

If a check has failed, a red X or yellow warning sign will appear.

Errors must be corrected before simulation.

2. Verify that the design has passed all checks. If it has no, return to the previous steps in this
guide and look for missteps.

Launching the Simulation
If you have no errors from the validation check, you are ready to launch the field solvers.

1. In the project tree, click Analysis to expand it.

Setup1 is listed.

2. Right-click Setup1, and select Analyze.

Q3D begins to mesh and solve the problem. The Progress window displays a progress
bar.
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3. To view details about the ongoing solution, right-click Setup1, and select Convergence.

The Solutions window appears.

This window shows how the mesh grows from one adaptive solution pass to the next and
how much the solution changes (delta%) between passes.

4. Click theMatrix tab to see the actual capacitance solution data.
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5. Click the Profile tab to see run-time profile information, such as the amount of CPU time
or memory used in the solution.

6. Click Close.

Generating a Field Plot
Field plots represent basic or derived quantities on surfaces or objects. You will now generate a
field plot on Via.

1. In the modeling workspace, select Via1.
2. SelectQ3D Extractor > Fields > CG Fields >Q > SmoothQ.

The Create Field Plot window appears.

3. Leave the default values unchanged, and click Done.

The resulting plot shows the charge when 1V is applied to Via and 0V is applied to
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GroundPlane.

Exporting a Circuit Model
Now that you have the solution, you will export a SPICE model to simulate the effects of the via
on a signal that passes through it.
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1. From the Project Manager, right-click Setup1 and select Export Circuit.

The Export Circuit window appears.

2. Leave the default settings, and click Export Circuit.

The file is exported as via_gsg.cir. Amessage window confirms the location and file
name.

3. ClickOK.

Currently, the model uses a single value for the variables padrad (0.6mm) and viarad (0.2mm).

Next, you will set up a parametric analysis to sweep the variables over a range of values. Then,
you can export different equivalent circuit models corresponding to the different values of these
variables.
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4 - Setting Up a Parametric Analysis
This section explains how to perform the following tasks:

l Adding a parametric sweep
l Running the parametric analysis

Adding a Parametric Sweep
A parametric setup is made up of one or more variable sweep definitions. A variable sweep
definition is a set of variable values within a range that Optimetrics drives Q3D to solve when the
parametric setup is analyzed. You can add one or more sweep definitions to a parametric setup.

1. ClickQ3D Extractor >Optimetrics Analysis > Add Parametric.

The Setup Sweep Analysis window appears.

2. On the Sweep Definitions tab, click Add.

The Add/Edit Sweep window appears.

3. Use the Variable drop-down list to select viarad.
4. Ensure that Linear Step is selected.
5. Specify the following values:

Start 0.2mm
Stop 0.5mm
Step Size 0.05 mm
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6. Click Add.

The variable viarad appears in the column to the right.

7. ClickOKto exit the Add/Edit Sweep window and return to the Setup Sweep Analysis
window.

The variable viarad now appears in the list.

8. Click the Table tab to see all the values of viarad that will be simulated.
9. ClickOK.
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Q3D Extractor simulates the model with various values in the specified range, including
the start and stop values.

The frequency sweep is listed in the Project Manager underOptimetrics as
ParametricSetup1.

Running the Parametric Analysis
Run the parametric analysis that was set up in the last step:

1. From the Project Manager, right-click ParametricSetup1, and select Analyze.

The Progress window displays the progress.

2. When the analysis has finished, right-click ParametricSetup1 and select View Analysis
Result.

The Post Analysis Display dialog box appears, showing a table listing the values of
viarad that have been solved.

3. Click the Profile tab to see how long it takes to solve each variation.
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5 - Comparing Results
This section explains how to perform the following tasks:

l Creating a plot of the parametric sweep
l Changing the pad radius and viewing its effect on capacitance

Plotting the Results
1. From the Project Manager, right-click Results and then select Create Matrix Report >

Rectangular Plot.

The Report window appears, on the Trace tab.

l In theQuantity list, select C(Via1,Via1).
l Use the Primary Sweep drop-down menu to select viarad.

2. Click New Report.
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A graph appears. The X axis reads viarad, and the Y axis reads C(Via1, Via1).

The graph shows that the via capacitance is only slightly affected by the radius of the center
barrel: the change in capacitance is from 645.75 pF to 652.5 pF. There is about 0.2% variation in
capacitance when via radius changes by a factor of 2.5 times (200 to 500).

Next, you'll generate another parametric sweep by changing the pad radius to see to its effect on
the capacitance.

Modifying the Pad Radius
1. ClickQ3D Extractor >Optimetrics Analysis > Add Parametric.

The Setup Sweep Analysis window appears.

2. Under the Sweep Definitions tab, click Add.

The Add/Edit Sweep window appears.

3. Click padrad from the Variable pull-down list.
4. Verify that Linear Step is selected.
5. Specify the following values:
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Start 0.5mm
Stop 1.1mm
Step Size 0.1mm

6. Click Add.

The variable padrad appears in the list to the right.

7. ClickOK to exit the Add/Edit Sweep window and return to the Setup Sweep Analysis
window.

8. ClickOK to close the Setup Sweep Analysis window.

The frequency sweep is listed in the Project Manager underOptimetrics as
ParametricSetup2.

Running and Plotting Second Parametric Analysis
Now you can run another parametric analysis.

1. From the Project Manager, right-click ParametricSetup2, and select Analyze.

The Progress window displays a progress bar.

2. When the simulation has finished, right-click ParametricSetup2 and select View
Analysis Result.

The Post Analysis Display dialog box appears, listing the values of padrad that have
been solved.

3. Close the window.

Just as you did previously, plot this parametric analysis:

1. In the Project Manager, right-click Results and select Create Matrix Report >
Rectangular Plot.

The Report window appears, on the Traces tab.

2. In theQuantity list, select C(Via1,Via1).
3. Use the Primary sweep drop-down menu to select padrad.
4. Click the Families tab. Select the Sweeps radio button, and then select the viarad row.
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5. Click the ellipses (...) button in the viarad row to specify sweep values for viarad:
l Ensure that the Select Values radio button is enabled.
l Ensure that 0.2mm is selected in the list. During the sweep, viarad will remain constant
at 0.2mm.

6. Click New Report to generate the graph.
7. Click Close to exit the Report window.

A graph appears, displaying the variation of the via capacitance (y axis) versus the pad radius (x
axis).
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This graph shows a much stronger effect from the pad radius than from the center barrel radius.
The capacitance changes from 0.585 pF to 1.250 pF (over 100% variation) over the range of the
sweep.
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6 - Closing the Project and Exiting
Electronics Desktop

Congratulations! You have successfully completed theGetting Started with Q3D Extractor: A
PCB Via Model guide. You may close the project and exit the software.

1. Click File > Save.
2. Click File > Close.
3. Click File > Exit.

Note:

If you enabled Legacy View Orientation earlier, you may wish to disable it now.
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